Installation

Requirements

RubyOSA requires Ruby 1.8.4 or later and Mac OS X 10.4 (Tiger) or later. Ruby 1.8.5 is recommended.

RubyGems

RubyOSA is still under development but it's already complete enough to be useful. The latest release available is 0.4.0.

The easiest way to install it is via RubyGems:

$ sudo gem install rubyosa

There is also a fink package available.

Subversion

Technically savvy people can fetch the sources and build the project by themselves, following the indications in the README file. It is also possible to grab the latest bits from the SVN repository.

Testing the Installation

Once you have RubyOSA installed on your machine, you can start controlling applications using the instructions in the Guide.